main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Other broadband queries

Wireless channel selection missing in expert mode?

SOLVED
View solved solution
Jayach
16: Advanced member

OMG again. It's now not working for me in any browser on PC or Linux, but is still working on Android phone in both browsers (Chrome and Opera tried) and also the app (and I powered the phone off/on just in case something was cached). Weird.

Edit: That was my error, it was still working in all browsers, see my later post.

View more options
MickJ
3: Seeker

And it's March the 1st not April the 1st  😉

View more options
_rik_
4: Newbie

@Jayach

if I were you I would be a bit scary living with such router around... I think it's gaining consciousness! 😱 😁!

One of these days while you are trying to change some settings, you could hear the router saying: "I'm sorry Dave, I'm afraid I can't do that!" 🤣

https://youtu.be/ARJ8cAGm6JE

 

View more options
Jayach
16: Advanced member

@_rik_

It possibly knows I've already got another ready to replace it. I quite like the hardware of this router so I got a Technicolor DGA4231 off eBay as it appears to be the same hardware in a different box which I prefer the look of, it's got twinkly green LEDs!!. I opened them up and it's exactly the same motherboard but with Technicolor firmware.

Any way I booted up my other THG3000 (firmware 19.2.0203-3261005) and it behaves the same, no channel selection on PC but there is when using an Android browser (Silk on Fire tablet this time).

Don't know it anyone else could try using a browser on Android?

Edit: Ignore that, it was me being dumb!

View more options
MickJ
3: Seeker

Thanks @_rik_   one of my favourites,  I can remember when HAL was seen as a one letter step from IBM

who I hear you say............

View more options
Cynric
9: Established

We used to say the same of ICL too 😁

View more options
_rik_
4: Newbie

@Jayach

Maybe the older firmware has the channel selector hidden and the developers forgot to set the "hide" class when the media query triggers the css modifications. If that's the case, with such older firmware, try to resize the desktop browser to the size of the android browser. If nothing happens, press F5 once resized. Try also CTRL+F5.

Could also be a matter of User Agent.

With the newer firmware I've tried all the size from 200px to 1920+. No result. I've also tried 20 different User Agent. No useful result.

 

However in the new firmware there isn't any channel selection field, not even hidden, so there is no chance to see it coming up from nowhere unless server side the router uses the UA to alter the HTML (very low probability because I can see some UA management client side.... by the way I can see they manage some UA except Firefox and maybe it's the reason it's the only browser with problems  in the wifi general tab not allowed to save the settings  https://forum.vodafone.co.uk/t5/Other-broadband-queries/Vodafone-Wi-Fi-Hub-bug-in-web-GUI-cannot-cha... ).

In the newer firmware I can only see hidden:

- the "Periodic autoscan" (off or selection of minutes) 

- the "Auto mode" with values "All channels" or "Compatibility".

Both are not working. I've tried to force them in any way possibile, via css, via JS, resending changing values in the http post header. The values are received, the nginx return the json success reply, but the router ignore them and goes on on channel 64.

I've also removed the list of channels over 48, even from the list of high channels (so the compatibility and "all channels" were identical),  and sent it back to the router server: no difference, still on channel 64.

So, I think they have disabled the function completely, server side. To override the server side code the only way is to obtain the firmware source code, modify it, compile, upload it back to the router. Too much work for a thing that should be there in the first instance!

The ridiculous thing is that in this firmware you can read this message in the id="auto-compChannel-info"

 

The Compatibility Mode will find the best channel from 36, 40, 44, and 48.<br>
It is possible to use All Channels Mode or manually configure one of the other available channels using the Channel dropdown.<br>
Note: Not all client devices support channels above 48.<br>
If you're unsure of what these options do, we recommend you maintain the default settings.

 

Such message is 100% gold, but what they call "default settings" is what they have just removed and I'm just facing the problems such message was talking about! 😣

View more options
Jayach
16: Advanced member

@Cynric wrote:

We used to say the same of ICL too 😁


I worked for them (before and after) for 42 years, we said it meant "it comes later".

View more options
Cynric
9: Established

I had the pleasure of using 1903 (George), various 29xx (VME), series 39 (VME), DRS 6000 (SVR4) and all the little DRS ones. Happy memories.

View more options
Jayach
16: Advanced member

@_rik_

My earlier confusion between desktop and mobile browsers was due to the desktop opening on WiFi general and the mobile version opening directly on WiFi settings. I have no excuse other than stupidity.

So it is actually working in all browsers and the app on both firmwares. I attach pics as proof.

Why it works here I don't know and it can't be something done server side as the router with the older firmware hasn't been online for at least 2 weeks.

View more options
Jayach
16: Advanced member

@Cynric wrote:

I had the pleasure of using 1903 (George), various 29xx (VME), series 39 (VME), DRS 6000 (SVR4) and all the little DRS ones. Happy memories.


I came from the English Electric side so LEO's, System 4, 7502's and other comms kit followed by DRS's and Fujitsu servers.

View more options
_rik_
4: Newbie

Full of young people here!😄

By the way I was developing software at the time of cp/m on Z80 CPUs...

View more options